Archiv der Kategorie: openwrt

Linux distribution for embedded devices.
Instead of trying to create a single, static firmware, OpenWrt provides a fully writable filesystem with package management. This frees you from the application selection and configuration provided by the vendor and allows you to customize the device through the use of packages to suit any application. For developer, OpenWrt is the framework to build an application without having to build a complete firmware around it; for users this means the ability for full customization, to use the device in ways never envisioned.

gl-ar300m nand aka pineapple +oled(ssd1306)+rtl8187-ic2-gpio-custom full ubi storage access

haha

shit video of botloog without any notice of misfunctionor else without modding bootlog :)

DOWNLOAD:
gl-ar300m-NAND-oled-pineapple-20171017_235036.tar.7z

endlich habe ich schon wieder einmal die pineapple firmware portiert. der mega geile gl-ar300m war einfach perfekt dafür.
zu beginn habe ich für den nor speiche die firmware mit openwrt  buildroot-cc gebaut. ging ohne probleme.

debian 8.9 (x64) VMWAREIAMGE OSBOXES:
su
apt-get update
apt-get install subversion build-essential git-core libncurses5-dev zlib1g-dev gawk flex quilt libssl-dev xsltproc libxml-parser-perl mercurial bzr ecj cvs unzip git wget sudo 
git clone https://github.com/domino-team/openwrt-cc.git
git clone https://github.com/devttys0/binwalk.git
cd binwalk
./debs.sh
sudo python3 setup.py install
 wget -O upgrade-1.1.3.bin https://www.wifipineapple.com/downloads/nano/1.1.3

[email protected]:~/Downloads$ binwalk -te upgrade-1.1.3.bin

DECIMAL HEXADECIMAL DESCRIPTION
——————————————————————————–
512 0x200 LZMA compressed data, properties: 0x6D,
dictionary size: 8388608 bytes, uncompressed
size: 3420708 bytes
1134468 0x114F84 Squashfs filesystem, little endian, version 4.0,
compression:xz, size: 13089146 bytes, 2102
inodes, blocksize: 262144 bytes, created:
2016-10-28 05:42:31
cd _upgrade-1.1.3.bin.extracted/
cp -R squashfs-root ../../openwrt-cc/files
# sqzashfs-root kopieren und ins buildroot verzeichnis als files #kopieren dei anderen dateien sind kernel welche wir ja sleber baue #und deshaltb ned benötigen da wir ja ein anadere hardware haben #als das original
cd /home/raimond/openwrt-cc/
rm -rf files/lib/modules/3.18.36
rm -f files/sbin/modprobe
## onion omeaga feed for oled easy handle like on onion board #COMMING SOON pienapple on onion omega (looking forward to #get the new onion2 omeaga) coming soon
echo “ src-git onion https://github.com/OnionIoT/OpenWRT-Packages.git“ >> feeds.conf.default
./scripts/feeds upate -a
./scripts/feeds install -a
##############################
##from any orginal image cp from it 2 files
#/etc/fw_env.config
#/etc/config/ubootenv
# uboot env should have !!!!!!!!!!!!!!!!!
#boot_dev=on
#u can lookup with fw_printenv

#if not already set , setit with :
fw_setenv boot_dev on
############################
#
#
echo „/dev/mtd1 0x0 0x10000 0x10000“ > files/etc/fw_env.config
#####
cat << EOF >> files/etc/config/ubootenv
config ubootenv
option dev ‚/dev/mtd1‘
option offset ‚0x0‘
option envsize ‚0x10000‘
option secsize ‚0x10000‘
EOF
################
# so und mit diesen 2 dateien habe ich dann acuh keinen kernel #panic mehr welche ich beim #den ersten versuchen auf dem nand #speicher hatte
#i2c oled ssd1306 einfach an den i2c pins hängen und mit dem #zusatz der leztzen zeile in der rc.local im buildroot wird dann nach #dem ersten neustart nach dem flashen der gesmte inhalt der jetzt #noch vorhanden rc.local gelöscht was in der letzten zeile eben #geschciht davor werden eingige config gesetzt ich habe natürlich #noch den cli für i2c kernel modul zu loaden dazugeschrieben der #geht halt erst nach dem man das board neugestartethat erst was #sowieso von slebst neubootet nach erfolgereichen flashen.
#voila
#pineapplpe fw mit 128 m speicher :))
#display mit oled-exp help nachscahuen easy 2 use
#ist natürclich auch scohn in der firmware fdrinnen habe auch alle #module uinstalliert alle gehen üproblemlos ohne jegliche #prolemem
#habe auch die dhp network confgi s angebpasst damit die 2 ethnet #anschlüsse funkkionieren und den usb0 der bei der nano fw ist #habe ich vorerwrtmal drinnen stehen gelassen
cd ~/openwrt-cc
./scripts/feeds update -a
 ./scripts/feeds install -a
make menuconfig
make

for nand flash benütze die img datei welche nach erfolgreichen build im bin/ar71xx  zu finden ist

einfach mit binwalk die upgrade firmware geloaded  von wifipineapple nano 1.3  version

binwlak (pythonicht auf den nor speicher welcher ganz ohne probleme zu  bauen ging sonden auf den 128 mb großen nand speicher.

gl-ar300m added oled ssd1306

GL-AR300M – GLI

mit oled display ssd1306

(und das geilste auf dem norflash speicher ist pienapple firmware einfash per switch button umschalten)

 

info from
https://wiki.onion.io/tutorials/cross-compile
https://wiki.openwrt.org/doc/hardware/port.i2c
https://github.com/domino-team/openwrt-cc
https://github.com/mkschreder/hack-ssd1306-openwrt

feeds.conf:

src-git packages https://github.com/openwrt/packages.git;for-15.05
src-git luci https://github.com/openwrt/luci.git;for-15.05
src-git routing https://github.com/openwrt-routing/packages.git;for-15.05
src-git telephony https://github.com/openwrt/telephony.git;for-15.05
src-git management https://github.com/openwrt-management/packages.git;for-15.05
src-git shadowsocks https://github.com/shadowsocks/openwrt-feeds.git
src-git onion https://github.com/OnionIoT/OpenWRT-Packages.git
#src-git targets https://github.com/openwrt/targets.git
src-git oldpackages http://git.openwrt.org/packages.git
#src-svn xwrt http://x-wrt.googlecode.com/svn/trunk/package
#src-svn phone svn://svn.openwrt.org/openwrt/feeds/phone
#src-svn efl svn://svn.openwrt.org/openwrt/feeds/efl
#src-svn xorg svn://svn.openwrt.org/openwrt/feeds/xorg
#src-svn desktop svn://svn.openwrt.org/openwrt/feeds/desktop
#src-svn xfce svn://svn.openwrt.org/openwrt/feeds/xfce
#src-svn lxde svn://svn.openwrt.org/openwrt/feeds/lxde
#src-link custom /usr/src/openwrt/custom-feed

 

 

my build gl-ar300m-oled-20171016_190635.tar.7z
Download avaiable at:
http://dl.raimond.org

http://dl.raimond.org/gl-ar300m-oled-20171016_190635.tar.7z

 

 

opkg install oled-exp libonionoledexp

opkg install kmod-i2c-gpio-custom kmod-i2c-core
insmod i2c-dev
insmod i2c-gpio-custom bus0=0,17,16

check
dmesg

 

ea6200 AC900 linksys open tha case tty console

bricked device !

ea6200 linksys router

Broadcom BCM47081A0
Gigabit in BCM47081A0

RAM 128MB
FLASH 128MB
Broadcom BCM43217
2×2 802.11b/g/n transceiver
Broadcom BCM4352
2×2 802.11a/b/g/n/ac transceiver
– RMFD RFFM4501
802.11a/n/ac Front End Module (x3)

1 console

es sind sogar 2 Serial console anschlüsse am ea6200 linksys router vorhanden einer davon 4 Pins von links nach rechts
VCC   # sollte nicht angeschlossen werden
TX # dieser ist mit dem gelben kabel verbunden und wird am UART anschluss  auf rx  nageschlossen
RX # und hier genau umgekehrt
GND # und masse sollte immer als erstes angeschlossen werden am besten sollte der

mittels Screen ,cu oder minicom etc 115200 8n1 sind die zu übergebeneden parameter

 

ausgeschalten sein damit mann auch den boot Prozess beobachten kann

bevor man herum  spielt sollte  man auf jeden fall die cfe.  sichern

 

zu beginn ist es möglich uboot params zu übegeben
mittels “ help“ in die console  eingegeben erhält man einen überblick aller verfügbaren befehle :
 
Available commands:
mfg                 Do a verify functionality of the major H/W components: nand flash/led/buttons
gpio                GPIO pins control
flashrw             Flash Read/Write.
devinfo             devinfo utility.
nvram               NVRAM utility.
reboot              Reboot.
set console         Change the active console device
loop                Loop a command
flash               Update a flash memory device
memtest             Test memory.
f                   Fill contents of memory.
e                   Modify contents of memory.
d                   Dump memory.
u                   Disassemble instructions.
batch               Load a batch file into memory and execute it
go                  Verify and boot OS image.
boot                Load an executable file into memory and execute it
load                Load an executable file into memory without executing it
save                Save a region of memory to a remote file via TFTP
ping                Ping a remote IP host.
arp                 Display or modify the ARP Table
ifconfig            Configure the Ethernet interface
show clocks         Show current values of the clocks.
show heap           Display information about CFE’s heap
show memory         Display the system physical memory map.
show devices        Display information about the installed devices.
unsetenv            Delete an environment variable.
printenv            Display the environment variables
setenv              Set an environment variable.
help                Obtain help for CFE commands
 
 
 
 
 
 
Decompressing…done
Decompressing…done
Found a Samsung NAND flash:
Total size:  128MB
Block size:  128KB
Page Size:   2048B
OOB Size:    64B
Sector size: 512B
Spare size:  16B
ECC level:   8-bit
Device ID: 0xec 0xf1 0x00 0x95 0x40
find_devinfo: devinfo block found at 0x00180000!
CFE version 6.39.163.14 (r374748) based on BBP 1.0.37 for BCM947XX (32bit,SP,)
Build Date: Tue Jun 11 11:59:51 CST 2013 ([email protected]), for the WG9116FAC22_88 board
Copyright (C) 2000-2008 Broadcom Corporation.
Copyright (C) 2013 Arcadyan Corporation.
WG9116FAC22_88 board, flashing LED…
Init Arena
Init Devs.
Boot partition size = 262144(0x40000)
DDR Clock: 400 MHz
Info: DDR frequency set from clkfreq=800,*400*
et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 6.39.163.14 (r374748)
CPU type 0x0: 800MHz
Tot mem: 131072 KBytes
CFE mem:    0x00F00000 – 0x0109240C (1647628)
Data:       0x00F58A9C – 0x00F58FC0 (1316)
BSS:        0x00F58FD0 – 0x00F9040C (226364)
Heap:       0x00F9040C – 0x0109040C (1048576)
Stack:      0x0109040C – 0x0109240C (8192)
Text:       0x00F00000 – 0x00F4C2B4 (311988)
Boot:       0x01093000 – 0x010D3000
Reloc:      I:00000000 – D:00000000
Boot version: v0.5.6
Device eth0:  hwaddr 98-FC-11-F3-5A-F3, ipaddr 192.168.10.2, mask 255.255.255.0
        gateway not set, nameserver not set
 
CFE> ▒▒Decompressing…done
Decompressing…done
Found a Samsung NAND flash:
Total size:  128MB
Block size:  128KB
Page Size:   2048B
OOB Size:    64B
Sector size: 512B
Spare size:  16B
ECC level:   8-bit
Device ID: 0xec 0xf1 0x00 0x95 0x40
find_devinfo: devinfo block found at 0x00180000!
CFE version 6.39.163.14 (r374748) based on BBP 1.0.37 for BCM947XX (32bit,SP,)
Build Date: Tue Jun 11 11:59:51 CST 2013 ([email protected]), for the WG9116FAC22_88 board
Copyright (C) 2000-2008 Broadcom Corporation.
Copyright (C) 2013 Arcadyan Corporation.
WG9116FAC22_88 board, flashing LED…
Init Arena
Init Devs.
Boot partition size = 262144(0x40000)
DDR Clock: 400 MHz
Info: DDR frequency set from clkfreq=800,*400*
et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 6.39.163.14 (r374748)
CPU type 0x0: 800MHz
Tot mem: 131072 KBytes
CFE mem:    0x00F00000 – 0x0109240C (1647628)
Data:       0x00F58A9C – 0x00F58FC0 (1316)
BSS:        0x00F58FD0 – 0x00F9040C (226364)
Heap:       0x00F9040C – 0x0109040C (1048576)
Stack:      0x0109040C – 0x0109240C (8192)
Text:       0x00F00000 – 0x00F4C2B4 (311988)
Boot:       0x01093000 – 0x010D3000
Reloc:      I:00000000 – D:00000000
Boot version: v0.5.6
Device eth0:  hwaddr 98-FC-11-F3-5A-F3, ipaddr 192.168.10.2, mask 255.255.255.0
        gateway not set, nameserver not set
 
 
Variable Name        Value
——————– ————————————————–
BOOT_CONSOLE         uart0
CFE_VERSION          1.0.37
CFE_BOARDNAME        BCM947XX
CFE_MEMORYSIZE       131072
NET_DEVICE           eth0
NET_IPADDR           192.168.10.2
NET_NETMASK          255.255.255.0
NET_GATEWAY          0.0.0.0
NET_NAMESERVER       0.0.0.0
STARTUP              go;
*** command status = 0

openwrt spoof all to local web server

ganz einfacher redirect

unter /etc/config/firewall

 

config redirect
option src lan
option proto tcp
option src_dport 80
option src_ip !192.168.1.1       
 #hier die locale ip adresse vom router die nicht gespoofed werden #soll sondern alle anderen
option dest_port 80

für port http

ziel von den anfragen solllen hier landen am router

option dest_ip 192.168.1.1
option target DNAT

 

#und dsas ganze nochmal für https

config redirect
option src lan
option proto tcp
option src_dport 443
option src_ip !192.168.1.1
option dest_port 443
option dest_ip 192.168.1.1
option target DNAT

ausserdem noch hinzufügen bei
/etc/config/dhcp

config ‚domain‘
option name ‚#‘
option ip ‚192.168.1.1‘


die sollten wegkommentiert werden

#list rebind_domain example.lan 
#option local ‚/lan/‘
#option domain ‚lan‘
#list server ‚/mycompany.local/1.2.3.4‘
#option nonwildcard 1
#list interface br-lan
#list notinterface lo
#list bogusnxdomain ‚64.94.110.11‘

HORNET U-BOARD X2 64/16 aka UB64

original ub64 files if someone need that

[ ] ART.bin 2016-05-18 03:54 64K  
[ ] NVRAM.bin 2016-05-18 03:54 64K  
[ ] rootfs.bin 2016-05-18 03:54 14M  
[ ] u-boot-env.bin 2016-05-18 03:54 64K  
[ ] u-boot.bin 2016-05-18 03:54 256K  
[ ] uImage.bin 2016-05-18 03:54 1.6M  

http://dl.raimond.at/hornet-ux2/

tftpboot 0x80600000 kernel.bin
erase 0x9fe50000 +0x190000
cp.b 0x80600000 0x9fe50000 120000

tftp 0x80600000 rootfs.bin
erase 0x9f050000 +0xE00000
cp.b 0x80600000 0x9f050000 240000

 

pineapple

Lost my pineapple mark5 alias mk5 in peru

so i wanted to get a new one and saw there is an pienapple nano and tera avaible at hak5

i grabbed  the firmware, binwalked it .
(get it from github or via apt)

cut kernel, rootfs etc out from the upgrade file and here ist the roofs  as bin just swquah it with or get it extraced her:

http://dl.raimond.org

bought me an hornet board with 64 named x2

there is also the original hornet x board firmware avaiable in all parts  rootfs kernel etc also from firmware udprage file

http://dl.raimond.at/hornet-ux2/

HORNET UBOARD ALFA + USBHUB+ RTL8187